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1 Introduction

In this chapter... ■ Overview, 1-2

■ Agilent ITF Overview, 1-3
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Chapter 1: Introduction: Overview

Overview Welcome to the Intelligent Test Framework (ITF) 
Administration System!

The ITF Administration System is a browser-based 
application used to configure system properties, such as 
user access, repair configurations and framework 
services, within the Agilent Repair Tool, the Agilent 
Quality Tool, and other ITF applications. For more 
information on the ITF, see Agilent ITF Overview.

The purpose of the ITF Administration System is to 
provide security and control functionality for the 
following items:

■ Users

■ Agilent Repair Tool

■ Agilent Quality Tool

■ Agilent Intelligent Test Framework

The ITF Administration System Help files allow you to 
quickly and easily find information about the ITF 
Administration System. Click any topic in the Help 
Table of Contents for information on that topic.

NOTE
The ITF Administration System can only be run 
from the ITF Server or a Client PC.
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Agilent ITF 
Overview

The ITF Administration System is part of the Agilent 
Intelligent Test Framework and is located on the ITF 
Server.

The Agilent Intelligent Test Framework provides a 
standards-based, scalable platform for use with 
manufacturing test equipment and applications. The ITF 
uses a three-tier, web-server architecture that enables 
scalability and extensibility.

The architecture is made up of the following tiers:

1 Data acquisition � A back-end population service 
that gathers raw data, such as log files, .res files, etc. 
from Agilent 5DX, Agilent 3070, Agilent SJ Series 
and Agilent SP Series test systems.

2 Intelligent Test Framework (ITF) Server � A 
server that collects and maintains test and repair data 
for use by the Client PC applications. It stores test 
results, images and CAD information. It also serves 
as a conduit for applications to retrieve information 
from the data store.

3 Client applications � Software that allows for data 
sharing and communication between Agilent 3070, 
5DX, SJ, and SP test systems. Examples include the 
Agilent Repair Tool and the Agilent Quality Tool. 
The number of client applications connected to the 
Intelligent Test Framework is dependent upon the 
number of licenses purchased.

Figure 1-1 Agilent Intelligent Test Framework Overview
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2 ITF Administration System Menu

In this chapter... ■ Overview, 2-2

■ Help, 2-3

■ Logging In and Logging Out, 2-5
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Chapter 2: ITF Administration System Menu: Overview

Overview The ITF Administration System Menu provides access 
to the following categories of information:

■ Users

■ Applications

■ Framework

■ Help

■ Resource

■ Logout

Figure 2-1 Agilent ITF Administration System
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Help The Help menu option in the ITF Administration System 
allows you to search the browser-based online help 
system or view software version information.

To access the Help information:

1 Click Help on the main menu.

2 Select one of the following choices:

■ Contents - View online help topics.

■ About - View software version information. The 
ITFSS 3.1 CD serial number is displayed in the 
About screen of the Administration System for 
your easy reference. See Figure 2-2.

Figure 2-2 About - ITFSS 3.1 CD Serial

Printable Help
The complete ITF Administration System help file is 
available in a printable format on the ITF Server.

To view a printable version of the ITF Administration 
System User Guide:

■ Click Start > Programs > ITF Software Solutions 
3.1 > ITF Test Framework > Printable Help on the 
ITF Server.

■ Or browse to 
C:\Agilent\ITFSS3.1\ITF\manuals\

AdminHelp.pdf, where 
C:\Agilent\ITFSS3.1\ITF is the default ITF 
install directory.

NOTE
You will need Adobe Reader® software to view 
and print the file.

To install Adobe® Reader:

1 Insert the ITFSS3.1 CD into the CD-ROM drive. 

2 Browse to <cd-rom drive>:\Acrobat directory on 
the ITFSS3.1 CD.

3 Double-click AdbeRdr602_distrib_enu.exe.

4 Follow the installation instructions and accept all 
default settings.
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You can also go to Adobe®�s web site at 
http://www.adobe.com and click the Acrobat Reader 
icon on the home page to download and install the latest 
version of Adobe® Reader.

http://www.adobe.com
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Logging In and 
Logging Out

When the ITF Administration System starts up, the first 
screen you see is the Login page. The Login page 
prevents unwanted access and allows you to log in to the 
ITF Administration System.

To log in to the ITF Administration System:

1 Double-click the ITF Administration System desktop 
icon on the ITF Server. 

This opens the browser-based ITF Administration 
System application login page.

2 Enter your user name and password in the comment 
boxes.

3 Click Login to gain access to the system.

Figure 2-3 Administration System - Login screen

Logout

The Logout button allows you to log out of the ITF 
Administration System.

To log out:

1 Click Logout on the main menu.

This opens a dialog box asking you to confirm the 
logout.

Figure 2-4 Microsoft Internet Explorer dialog box

2 Click OK to log out of the application.

NOTE
If the ITF Administration System is closed by 
clicking the in the top right corner of 
the screen, this closes the browser but does not log 
out the user. The �hanging login� terminates after 
a preset time (approximately 20 minutes).

To log out users from the ITF Administration System 
and other applications, see Force Logout.
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3 Users

In this chapter... ■ Overview, 3-2

■ User Roles, 3-3

■ Setting Up User Accounts, 3-11

■ Force Logout, 3-16
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Chapter 3: Users: Overview

Overview The Users menu option in the ITF Administration 
System allows you to add and edit user data, as well as 
force user logouts.

To manage users:

1 Click Users on the main menu. 

2 Select one of the following choices:

■ Setting Up User Accounts - Add new users, edit 
user data and roles.

■ Force Logout - Allows the Administrator to log 
out all users who are currently logged in to the 
ITF, in case of a maintenance, service, or 
emergency shutdown.
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User Roles The following subsections describe the user roles 
available in the Administration System and the 
permissions granted to each role.

Available User Roles
Each user must have at least one assigned role. Each 
role allows for a different level of access to the ITF 
Administration System and other ITF applications.

The following roles can be assigned to individuals:

■ Administrator Role

■ Repair Administrator Role

■ Repair User Role

■ Quality Administrator Role

■ Quality User Role

NOTE
The System Administrator role cannot be 
assigned. It is a permanent account that has the 
unique ability to assign other users the 
Administrator role. However, the password can be 
changed.

NOTE
To assign user roles, see Add a User.

Permissions
The following table shows page viewing and editing 
privileges in the ITF Administration System and 
privileges associated with ITF applications for the 
various user roles:

See Table 3-1

Table 3-1 User Role Chart

User Role Viewable information in 
ITF Administration System

Editable Information in ITF 
Administration System

Privileges Associated with ITF 
Applications

System 
Administrator

All All None
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Administrator All � Users

■ Password

■ Name

■ Create/assign/remove 
Repair Administrator, 
Qualitiy Administrator, 
Repair User, Quality User

� Applications - all
� Framework
� Resource
� Help

Same as Repair Administrator 
and Qualitiy Administrator.

Repair 
Administrator

� User accounts for Repair 
Administrator and Repair 
User

� Applications - Repair and 
General

� Help

� Users

■ Password

■ Name

■ Create/assign/remove 
Repair User

� Applications - Repair Only

Log in and use Agilent Repair 
Tool:
� Access Administration menu 

tabs
� Repair boards
� Change password

Table 3-1 User Role Chart

User Role Viewable information in 
ITF Administration System

Editable Information in ITF 
Administration System

Privileges Associated with ITF 
Applications
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Quality 
Administrator

� User accounts for Quality 
Administrator and Quality 
User

� Applications - Quality and 
General

� Help

� Users

■ Password

■ Name

■ Create/assign/remove 
Quality User

� Applications - Quality only

� Log on and use Agilent 
Quality Tool:

� Create Views
� Edit Views
� See charts based on operator 

(False:Real by Operator and 
False:Total Failed by 
Operator)

� Modify Chart Options, 
including:

■ Set Alarms

■ Set placement machine 
filter

■ Set �opportunities� for 
DPMO as pins and/or 
components

� Change password

Repair User None None Log on and user Agilent Repair 
Tool:
� Repair boards
� Change password

Table 3-1 User Role Chart

User Role Viewable information in 
ITF Administration System

Editable Information in ITF 
Administration System

Privileges Associated with ITF 
Applications
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System Administrator Role
The System Administrator role has the highest-level 
permissions of any account and is the only role that can 
assign or remove Administrator privileges. This role is 
automatically set up during installation with 
administrator privileges. This is a single, permanent 
account with login name �Administrator.�

The System Administrator has permission to view all 
pages in the ITF Administration System.

The System Administrator has permission to edit the 
following information in the ITF Administration 
System:

■ Users

� Password

� Name

� Create/assign/remove any role

■ Applications - all

■ Framework

■ Resource

■ Help

Quality User None None Log on and user Agilent Quality 
Tool:
� Open Views
� Drill-down to more charts 
� Save chart images
� Respond to alarms
� View the alarms
� Look at chart history or View 

history
� Change password

Table 3-1 User Role Chart

User Role Viewable information in 
ITF Administration System

Editable Information in ITF 
Administration System

Privileges Associated with ITF 
Applications
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The System Administrator cannot log on and use the 
Agilent Repair Tool or Agilent Quality Tool.

NOTE
The ability to add or remove roles applies to both 
the account you are currently logged in under and 
other accounts with lower permission levels.

Administrator Role
The Administrator role has the second-highest level of 
permission in the ITF Administration System. 
Permissions for this role are set by the System 
Administrator. There is no limit on the number of 
concurrent users logged in as Administrator.

Administrators can log on and use the Agilent Repair 
Tool or Agilent Quality Tool to do the following:

Agilent Repair Tool
■ Access Administration menu tabs

■ Repair boards

■ Change passwords

Agilent Quality Tool
■ Create Views

■ Edit Views

■ See charts based on operator (False:Real by 
Operator and False:Total Failed by Operator)

■ Change passwords

■ Modify Chart Options, including:

� Set Alarms

� Set placement machine filter

� Set �opportunities� for DPMO as pins and/or 
components

Administrators have permission to view all pages in the 
ITF Administration System.

Administrators have permission to edit the following 
information in the ITF Administration System:

■ Users

� Password

� Name

� Create/assign/remove the following roles � 
Repair Administrator, Repair User, Quality 
Administrator, Quality User

■ Applications - all

■ Framework

■ Resource

■ Help

The ability to add or remove roles applies to both the 
account you are currently logged in under and other 
accounts with lower permission levels.
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Repair Administrator Role
Users assigned to the Repair Administrator role can 
access only the Agilent Repair Tool configuration or 
administration features of the ITF Administration 
System. Permissions for this role are set by the System 
Administrator or Administrator role.

There are no restrictions on the number of users with 
Repair Administrator permissions. A System 
Administrator or an Administrator can assign an 
unlimited number of users or none to this role. There is 
no limit on the number of concurrent users logged in as 
Repair Administrator. A Repair Administrator can add 
Repair Users and other Repair Administrators.

Repair Administrators can log on and use the Agilent 
Repair Tool to do the following:

■ Access Administration menu tabs

■ Repair boards

■ Change password

Repair Administrators have permission to view the 
following pages in the ITF Administration System.

■ Users (accounts for):

� Repair Administrator

� Repair User

■ Applications - Repair and General

■ Help

Repair Administrators have permission to edit the 
following information in the ITF Administration 
System.

■ Users

� Password

� Name

� Create/assign/remove the following roles � 
Repair User

■ Applications - Repair only

The ability to add or remove roles applies to the account 
you are currently logged in under and other accounts 
with lower permission levels.

Repair User Role
Users assigned to the Repair User role have access only 
to the Agilent Repair Tool.

Permissions for this role are set by the System 
Administrator, Administrator or Repair Administrator. 
The maximum number of concurrent users is limited by 
your software license.

Repair Users can log on and use the Agilent Repair Tool 
to do the following:

■ Open and repair boards

■ Enter repair action and other related information

■ View available x-ray or optical images of 
potential defects

■ View ICT report tickets
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■ Change password

Repair Users do not have permission to view or edit 
information in the ITF Administration System.

Quality Administrator Role
Users assigned to the Quality Administrator role can 
access only the Agilent Quality Tool configuration or 
administration features of the ITF Administration 
System. Permissions for this role are set by the System 
Administrator or Administrator role.

There are no restrictions on the number of users with 
Quality Administrator permissions. A System 
Administrator or an Administrator can assign an 
unlimited number of users or none to this role. There is 
no limit on the number of concurrent users logged in as 
Quality Administrator. A Quality Administrator can add 
Quality Users and other Quality Administrators.

Quality Administrators can log on and use the Agilent 
Quality Tool to do the following:

■ Create Views

■ Edit Views

■ See charts based on operator (False:Real by 
Operator and False:Total Failed by Operator)

■ Modify Chart Options, including:

� Set Alarms

� Set placement machine filter

� Set �opportunities� for DPMO as pins and/or 
components

■ Change password.

Quality Administrators have permission to view the 
following pages in the ITF Administration System.

■ Users (accounts for):

� Quality Administrator

� Quality User

■ Applications - Quality and General

■ Help

■ Quality Administrators have permission to edit 
the following information in the ITF 
Administration System.

■ Users

� Password

� Name

� Create/assign/remove the following roles � 
Quality User

■ Applications - Quality only

NOTE
The ability to add or remove roles applies to the 
account you are currently logged in under and 
other accounts with lower permission levels.



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  3-10

Chapter 3: Users: User Roles

Quality User Role
Users assigned to the Quality User role have access only 
to the Agilent Quality Tool.

Permissions for this role are set by the System 
Administrator, Administrator or Quality Administrator. 
The maximum number of concurrent users is limited by 
your software license.

Quality Users can log on and use the Agilent Quality 
Tool to do the following:

■ Open Views

■ Drill-down to more charts

■ Save chart images

■ Respond to alarms

■ View the alarm log

■ Look at chart history or View history

■ Change password

NOTE
Quality Users cannot edit or create Views in the 
Agilent Quality Tool.

Quality Users do not have permission to view or edit 
information in the ITF Administration System.
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Setting Up User 
Accounts

The following subsections provide instructions on 
adding, editing and removing users. Instructions on 
changing user passwords are also provided.

Add a User
Each user must be assigned a login ID, password, and 
role in order to use any ITF application, such as the 
Agilent Repair Tool or ITF Administration System.

NOTE
Each login ID must be unique.

Once this information has been assigned to a user, their 
information is automatically added to the system�s data 
store and they can immediately access their assigned 
resources.

NOTE
This System Administrator account is set up 
automatically during installation. It is a permanent 
account that has the unique ability to assign other 
users an administrative role.

To add a user:

1 Click Users > Set Up on the main menu. 

This opens a data table with the Add User button 
located above it.

2 Click Add User. 
The Add User dialog box appears.
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Figure 3-1 Add User dialog box

3 Complete the user profile information, including the 
ID, first name, last name, and password.

NOTE
The login ID and password fields are 
case-sensitive and must contain a character string 
between 3 and 15 characters to be valid. Both 
numbers and letters are acceptable in the 
password. Be sure to follow your company�s 
guidelines for assigning passwords.

4 Choose one or more roles to assign the user by 
clicking on them in the Roles Available box.

NOTE
At least one role must be assigned to each new 
user or the user cannot be added to the data store.

5 Click Add > to assign the role(s) to the selected user.

The role is automatically moved to the Assigned 
Roles column.

NOTE
To assign all available roles to a user, click Add All 
>>.

6 Click Apply to save the user information.

Changes are applied immediately.
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Edit a User
You can edit a user�s login ID, name, password or 
role(s).

To edit user information:

1 Click Users > Set Up on the main menu. 

This opens a data table.

2 Locate the user�s name in the data table.

3 Click the Edit button on the same row as the user�s 
name. 

The Edit User dialog box appears with the user�s 
information.

4 Edit the user information.

NOTE
Editable fields vary by role. See Permissions for 
an overview of user roles and their assigned 
permissions.

5 Click Apply. 

Changes are applied immediately.

Figure 3-2 Edit users in the data table
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Remove a User
When you remove a user from the ITF Administration 
System, they are removed from the data store and no 
longer have access to ITF applications.

The System Administrator and Administrators have 
permission to remove any user. The Repair 

Administrator and Quality Administrator can only 
remove Repair Users or Quality Users, respectively.

To remove a user:

1 Click Users > Set Up on the main menu. 

This opens a data table similar to the one shown in 
Figure 3-3.

2 Locate the user�s name in the data table.

Figure 3-3 Remove User from the data table

3 Click the Remove button on the same row as the 
user�s name.

A dialog box appears, asking you to confirm the 
deletion of the user. See Figure 3-4.

4 Click OK to delete the user from the data store. 

5 Click Cancel to go back to the previous screen.

Figure 3-4 Delete User Confirmation dialog box
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Change Password
To change a user�s password:

1 Click Users > Set Up on the main menu. 

This opens a data table similar to the one shown in 
Figure 3-5.

2 Locate the user�s name, for example bwilliams, in 
the data table.

3 Click the Edit button on the same row as the user�s 
name. 

The Edit User dialog box appears with the user�s 
information.

4 Click the Change button located next to the Password 
field.

The Change Password dialog box appears. 

5 Enter the new password in the New Password text 
box. 

6 Re-enter the password in the Confirm New Password 
text box.

7 Click Apply. 

Changes are applied immediately.

Figure 3-5 Change Password dialog box
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Force Logout The Force Logout feature allows System 
Administrators, Administrators, Repair Administrators, 
and Quality Administrators to quickly log out users with 
lower-level permissions that are connected to the ITF 
Server. 

For instance, a Repair Administrator can log out a 
Repair User.

This is useful during maintenance, service, or 
emergency shutdowns.

To force user logouts:

1 Click Users > Force Logout from the main menu. 

A User Management data table similar to the one 
shown in Figure 3-6 appears.

2 Click the Logout button next to the user you want to 
log out of the system.

A dialog box appears, asking you to confirm the 
disconnection of the user. 

3 Click OK.

NOTE
If a user has logged in under multiple sessions, 
clicking Logout on one session will log the user 
out of all sessions, not just the one selected.

Figure 3-6 User Management data table
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4 Applications

In this chapter... ■ Overview, 4-2

■ Agilent Repair Tool, 4-3

■ Agilent Quality Tool, 4-19

■ General, 4-26



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  4-2

Chapter 4: Applications: Overview

Overview The Applications menu option in the ITF Administration 
System allows users to configure basic services for 
applications associated with the Intelligent Test 
Framework, such as the Agilent Repair Tool.

Click Applications from the main menu. Select one of 
the following choices:

■ Repair - Configure status buttons, repair actions, 
close board prompts, and function keys for use 
with the Agilent Repair Tool.

■ Quality - Configure chart options for use with the 
Agilent Quality Tool.

■ General - Configure defect lists and map test 
systems for use across several ITF applications.
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Agilent Repair Tool The Applications > Repair menu option in the ITF 
Administration System allows users to view, customize 
or edit the Agilent Repair Tool configuration data for 
AXI, AOI_SJ, AOI_SP, and ICT test system modes.

Administrators can configure the following items:

■ Status Buttons

■ Show Defect Details

■ Disable Status Button When Repair Is 
Required

■ Close Board

■ Repair Actions

■ Function Keys

Status Buttons
The Agilent Repair Tool has the ability to display the 
following status buttons:

■ Repaired
■ Repair Later
■ False Call
■ Variation OK

Agilent Technologies requires the Repaired and False 
Call buttons to appear in the Agilent Repair Tool (ART) 
interface. However, the Repair Later and Variation OK 
buttons are optional.

NOTE
To add or remove the Repair Later button in the 
ART application, see Show Repair Later 
Button.

To add or remove the Variation OK button in the 
ART application, see Show Variation OK 
Button.
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Show Repair Later Button
To display the Repair Later button in the Agilent Repair 
Tool:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Status Buttons.

The Status Buttons dialog box appears.

4 Select the Repair Later check box in the Show Button 
column to display the button in the selected test 
system mode (AOI_SJ, AOI_SP, AXI, or ICT) of the 
Agilent Repair Tool.

Figure 4-1 To display the Repair Later button in the Agilent Repair Tool

5 Click Apply. 

Changes are applied immediately.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI, and ICT).

To remove the Repair Later button from the Agilent 
Repair Tool interface, click the check box again, and 
then click Apply.
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Show Variation OK Button
To display the Variation OK button in the Agilent Repair 
Tool:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Status Buttons. 

The Status Buttons dialog box appears.

4 Select the Variation OK check box in the Show Button 
column to display the button in the selected test 
system mode of the Agilent Repair Tool.

5 Click Apply. 

Changes are applied immediately.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

To remove the Variation OK button from the Agilent 
Repair Tool interface, click the checkbox again, and 
then click Apply.

Figure 4-2 To display the Variation OK button



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  4-6

Chapter 4: Applications: Agilent Repair Tool

Show Defect Details
The Agilent Repair Tool can be configured to display 
the Defect Details dialog box when various status 
buttons are selected. The Defect Details dialog box 
allows the user to enter more specific details about 
repair actions and defects.

To display the Defect Details dialog box when specific 
status buttons are selected:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Status Buttons. 

The Status Buttons dialog box appears.

4 Select one or more of the check boxes in the Show 
Defect Details dialog box column to display the 
Defect Details dialog box when the corresponding 
status button (i.e., Repaired, False Call, etc.) is 
selected.

5 Click Apply. 

Changes are applied immediately.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Figure 4-3 Show Defect Details Dialog check boxes
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Disable Status Button When Repair Is Required
The ITF Administration System allows you to disable 
the Repair Later, False Call and/or Variation OK status 
buttons in the Agilent Repair Tool when certain defect 
types are being reviewed by repair operators. This helps 
ensure that the specified defects are always repaired by 
repair operators.

For more information on Repair Required defect 
settings, see Edit a Defect.

To disable status buttons when repair is required:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Status Buttons. 

The Status Buttons dialog box appears.

4 Select one or more of the appropriate check boxes in 
the Disable Button for Repair Required Defects 
column.

5 Click Apply. 

Changes are applied immediately.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Figure 4-4 Disable Button for Repair Required Defects
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Close Board
The ITF Administration System allows you to set the 
Close Board option for the Agilent Repair Tool. When a 
user attempts to close a board with active defects, one of 
the following options may be set:

■ Close board without warning
■ Close board with warning
■ Do not close board

To set the Close Board option:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Close Board. 

The Close Board Options dialog box appears.

4 Select the desired close board option.

5 Click Apply.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

NOTE
This feature applies only to boards with active 
defects. An active defect is a defect that needs to 
be reviewed by a repair operator and be marked 
either Repaired, Repair Later, False Call or 
Variation OK in the Agilent Repair Tool.

Figure 4-5 Close Board Options dialog box
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Repair Actions
The Defect Details dialog box in the Agilent Repair Tool 
is used by repair operators when assigning repair actions 
to defects. The list of repair actions in the Defects 
Details dialog box can be modified to meet your 
organization�s needs.

The following changes can be made to the repair actions 
list in the Defect Details dialog box:

■ Add a Repair Action

■ Edit a Repair Action

■ Remove a Repair Action

■ Restore a Repair Action

■ Reorder the Repair Action List

Figure 4-6 Defect Details dialog box in ART showing the repair action list
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Add a Repair Action
To add a repair action to the Agilent Repair Tool Defect 
Details dialog box:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Repair Actions. 

This opens the Repair Actions data table.

4 Click Add Repair Action at the top of the data table.

A new row appears as shown in Figure 4-7 at the top 
of the data table.

5 Enter the new repair action in the comment box.

6 Click Apply. 

Changes are applied immediately.

7 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).
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Figure 4-7 Adding a Repair Action
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Edit a Repair Action

To edit a repair action from the Agilent Repair Tool 
Defect Details dialog box:

1 Click the Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Repair Actions. 

This opens the Repair Actions data table.

4 Click the Edit button next to the repair action you 
want to edit. 

A dialog box similar to Figure 4-8 appears allowing 
the editing of the display name for the repair action.

5 Click Apply. 

The updated repair action will be listed in the Defect 
Details dialog box of the Agilent Repair Tool user 
interface.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).
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Figure 4-8 Editing a Repair Action
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Remove a Repair Action

To remove a repair action from the Agilent Repair Tool 
Defect Details dialog box:

1 Click the Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Repair Actions. 

This opens the Repair Actions data table.

4 Click the Remove button next to the repair action you 
want to remove. 

A dialog box appears as shown in Figure 4-9 asking 
you to confirm the deletion of the repair action.

5 Click OK. 

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

NOTE
You can hide the removed repair action from view 
by clicking Hide Removed Items at the top of the 
table. The removed item remains in the list, but it 
is hidden from view.

To restore the repair action, see Restore a Repair 
Action.

Figure 4-9 Confirming the removal of a repair action
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Restore a Repair Action
To restore a repair action in the Agilent Repair Tool 
Defect Details dialog box:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Repair Actions. 

The Repair Actions data table appears as shown in 
Figure 4-10. If removed repair actions are not 
currently listed in the table, click the Show Removed 
Items button at the top of the table. Removed repair 
actions are displayed in grayed-out rows and appear 
at the top of the table.

Figure 4-10 Removed repair actions displayed in grayed out rows on top

4 Click the Restore button for any repair actions you 
want to restore to the Defect Details dialog box. 
Changes are applied immediately.

5 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).
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Reorder the Repair Action List
To edit the order of the repair actions listed in the 
Agilent Repair Tool Defect Details dialog box:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Repair Actions. 

This opens the Repair Actions data table.

4 Click the Edit Order button located above the table.

This displays the Edit Display Order sort box.

5 Select the repair action that you wish to move by 
clicking it with your cursor.

6 Click the arrow next to the table to move the 
highlighted selection to a different location.

To move the selection up, click the  arrow. 

To move the selection down, click the  arrow.

7 Continue clicking the arrows until the repair action is 
in the desired location.

8 Repeat the above steps for any other repair actions 
you wish to reorder.

9 Click Apply. 

Changes are applied immediately

10 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Figure 4-11 Agilent Repair Tool Defect Details dialog box
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Function Keys
The Agilent Repair Tool is pre-programmed with the 
following function key shortcuts for frequent repair 
tasks. You can change the mapping of many of these 
function keys to meet your organization�s needs. To 
re-map a function key, see Map Function Keys.

■ F1 - Help > On Screen

■ F2 � File > Print Repair Report

■ F3 - Board > Clear Highlights

■ F4 � Defect > Next

■ F5 � Defect > Undo Repair Action

■ F6 � Defect > Repaired

■ F7 � Defect > Repair Later

■ F8 � Defect > False Call

■ F9 � Board > Rotate

■ F10 - File menu

■ F11 � User > Login/Logout

■ F12 � File > Exit

NOTE
Function keys F1 and F10 may not be 
reprogrammed.

Map Function Keys
To map the function keys (F2, F4, etc.) to a particular 
repair task:

1 Click Applications > Repair on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Function Keys. 

This opens the Function Keys data table. See Figure 
4-12.

4 Click the Edit button next to the function key you 
want to edit. 

This opens a dropdown menu in the Mapped To 
column.

5 Select the desired function from the list.

6 Click Apply. 

Changes are applied immediately.

7 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).
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Figure 4-12 Function Keys data table

Figure 4-13 Editting the Function keys data table
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Agilent Quality Tool The Applications > Quality menu option in the ITF 
Administration System allows users to view, customize 
or edit Agilent Quality Tool configuration data for AXI 
and AOI_SJ, AOI_SP test system modes.

Views
In particular, the Agilent Quality Tool requires users to 
create specific �Views� from which to look at or access 
their board data. The ITF Administration System helps 
you configure these �Views� for the following items:

■ Single Board Types

■ Multiple Board Types

Chart Descriptions
As part of a user's defined �Views,� the Agilent Quality 
Tool displays test and repair data in the form of trend or 
bar (Pareto) charts. The charts are selected using the ITF 
Administration System. The following table describes 
the various charts available for display in the Agilent 
Quality Tool.

Table 4-1 Charts Available for Display in AQT

Agilent Quality Tool Tab Name Charts Available for Display Description

Pre-Repair Quality First Pass Yield Percentage of board that passed test or 
inspecton

DPMO

(Defects per Million 
Opportunities)

Total number of failed pins, failed 
components, or both per million pins, 
components, or both tested.

Test Calls

(single board type only)

Number of failures listed by test call.

Failed Components

(single board type only)

Number of failed components, listed by 
reference designator.
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Failed Components by 
Feeder

(single board type only)

Number of failed components placed by a 
particular placement machine and feeder.

Boards tested Number of boards tested on the specified 
test stations(s).

First Pass Yield Percentage of boards that contain no real 
defects.

Calculations includes boards that passed 
test of inspection and boards that have 
been completely reviewed with the Agilent 
Repair Tool.

DPMO

(Defects per Million 
Opportunities)

Total number of defective pins, defective 
compoments, or both per million pins, 
components, or both tested.

Defects

(single board type only)

Number of defects, listed by defect name.
Calculations includes board that have been 
completely reviewed with the Agilent Repair 
Tool.

Defective Components 

(single board type only)

Number of defective components, listed by 
reference designator..

Table 4-1 Charts Available for Display in AQT

Agilent Quality Tool Tab Name Charts Available for Display Description
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Defective Components by 
Feeder

(single board type only)

Number of defective components placed by 
a particular placement machine and feeder.

Board Repaired Number of boards repaired using the 
Agilent Repart Tool.

Throughput Boards Tested Number of boards tested on the specified 
test station(s).

Boards Repaired Number of boards repaired with the Agilent 
Repair Tool.

First Pass Yield
(Pre-Repair)

Percentage of boards that passed test or 
inspection.

Boards Tested but Not 
Reviewed

Number of boards that failed test and have 
nott been completely reviewed with the 
Agilent Repair Tool.

False Call False PPM

(Parts Per Million)

Number of false-called pins, false-called 
components, or both per million pins, 
components, or both tested.

False:Real Ratio of false-called components (or 
false-called pins) to defective components.

False:Total Failed Ratio of false-called components (or 
false-called pins) to failed components (or 
pins).

Table 4-1 Charts Available for Display in AQT

Agilent Quality Tool Tab Name Charts Available for Display Description
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Single Board Types
The Agilent Quality Tool can display test and repair 
information in the form of trend and bar (Pareto) charts 
for single board types.

Charts are displayed under the following tabs in the 
Agilent Quality Tool interface:

■ Pre-Repair Quality

■ Post-Repair Quality

■ Throughput

■ False Call

You can select up to four different charts for each tab.

To configure charts for a single board type:

1 Click Applications > Quality on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click View Types, and then Single Board Type. 

The Single Board Type Charts dialog box appears.

Average False Calls Average number of false-called 
components (or false-called pins) per board 
tested.

False Called Components

(single board type only)

Number of false-called components, 
grouped by reference designator.

False Called Components 
by Alogrithm

(single board type only)

Number of false-called components, 
grouped by alogrithm.

False Called Components 
by Package Type

(single board type only)

Number of false-called components, 
grouped by package type.

Table 4-1 Charts Available for Display in AQT

Agilent Quality Tool Tab Name Charts Available for Display Description
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Figure 4-14 AOI_SJ Single Board Type Charts

At the top of the dialog box are four different chart 
layouts. The layouts show how the charts will be 
displayed in the Agilent Quality Tool interface 
depending on whether 1, 2, 3 or 4 charts are selected. 
For instance, if only one chart is selected (i.e., A), it 
will be displayed by itself in the center of the user 
interface. 

4 To select the charts for the Pre-Repair Quality tab, 
click the Edit button in the Pre-Repair Quality row.

5 Under the Displayed Charts column, click the 
drop-down menu for �A.� 

This displays a list of available charts. See Chart 
Descriptions for more information on the types of 
charts available.

6 Select the chart you want displayed in the �A� layout 
position by clicking it.

7 If you would like additional charts displayed under 
the Pre-Repair Quality tab, click the B, C and D 
drop-down menus, respectively, and select the 
various charts.

8 Click Apply when finished.
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9 Repeat the above steps for the Post-Repair Quality, 
Throughput, and False Call tabs.

NOTE
When changing chart options, the new layout only 
applies to new Views and not saved Views.

Multiple Board Types
The Agilent Quality Tool can display test and repair 
information in the form of trend charts for multiple 
board types.

Charts are displayed under the following tabs in the 
Agilent Quality Tool interface:

■ Pre-Repair Quality

■ Post-Repair Quality

■ Throughput

■ False Call

You can select up to four different charts for each tab.

To configure charts for multiple board types:

1 Click Applications > Quality on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click View Types, then Multiple Board Type. 

The Multiple Board Type Charts dialog box appears.

Figure 4-15 AOI_SJ Multiple Board Type Charts
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At the top of the dialog box are four different chart 
layouts. The layouts show how the charts will be 
displayed in the Agilent Quality Tool interface 
depending upon whether 1, 2, 3 or 4 charts are 
selected. For instance, if only one chart is selected 
(i.e., A), it will be displayed by itself in the center of 
the user interface. 

4 To select the charts for the Pre-Repair Quality tab, 
click the Edit button in the Pre-Repair Quality row.

5 Under the Displayed Charts column, click the 
drop-down menu for �A.� This displays a list of 
available charts. See Chart Descriptions for 
information on the types of charts available.

6 Select the chart you want displayed in the �A� layout 
position by clicking it.

7 If you would like additional charts displayed under 
the Pre-Repair Quality tab, click the B, C and D 
drop-down menus, respectively, and select the 
various charts.

8 Click Apply when finished.

9 Repeat the above steps for the Post-Repair Quality, 
Throughput, and False Call tabs.

NOTE
When changing chart options, the new layout only 
applies to new Views and not saved Views.



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  4-26

Chapter 4: Applications: General

General The Applications > General menu option allows you to 
configure features or services that apply to all ITF 
applications, such as the Agilent Repair Tool and 
Agilent Quality Tool.

You can configure the following features:

■ Defect List

■ Test Stations Display List

Defect List
The ITF Administration System helps you create and 
modify a standard list of defect types for use with both 
the Agilent Repair Tool and Agilent Quality Tool. This 
list can be modified to meet your organization�s needs.

The following changes can be made to the defect list:

■ Add a Defect

■ Edit a Defect

■ Remove a Defect

■ Restore a Defect

■ Reorder the Defect List

■ Assign Specific Repair Actions to a Defect
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Figure 4-16 Defect Details dialog box in ART showing defect list
.
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Add a Defect
To add a new defect type to the defect list:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Defects. 

This brings up the Defect List data table.

Figure 4-17 Defect List data table

4 Click the Add Defect button at the top of the data 
table. 

This opens an editable dialog box at the top of the 
data table.

Figure 4-18 Adding a defect
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5 Enter the new defect name in the Defect Name text 
box.

6 Enter the defect name as you would like it displayed 
in ITF applications in the Displayed As text box.

7 Select the Classification from the drop-down menu. 
Options include: Component, Pin, and Other. 
�Component� represents component-level defects, 
�Pin� represents pin-level defects, and �Other� is for 
all other classification levels.

8 Select whether a repair action is always required for 
this defect type. For instance, you may always want a 
SHORT repaired.

NOTE
If you select �Yes� for the Repair Required 
column, please see Disable Status Button When 
Repair Is Required for more information on 
configuring the Agilent Repair Tool for required 
repairs.

9 Click Apply. 

Changes are applied immediately.

10 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Edit a Defect
To edit a defect type in the defect list:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Defects.

This brings up the Defect List data table.

4 Click the Edit button next to the defect you want to 
edit. You can edit the Displayed As, Classification, 
and Repair Required comment boxes.

Figure 4-19 Defect List data table
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Displayed As: Enter the defect name as you would like it 
displayed in ITF applications in the Displayed As 
comment box.

Classification: Options include: Component, Pin, and 
Other. �Component� represents component-level 
defects, �Pin� represents pin-level defects, and �Other� 
is for all other classification levels.

Repair Required: Select whether a repair action is always 
required for this defect type. For instance, you may 
always want a SHORT repaired.

NOTE
If you select �Yes� for the Repair Required 
column, please see the section, Disable Status 
Button When Repair Is Required, for more 
information on configuring the Agilent Repair 
Tool for required repairs.

Figure 4-20 Defect List data table editable dialog box

5 After you have made the desired changes, click 
Apply. 

Changes are applied immediately.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).
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Remove a Defect
To remove a defect type from the defect list:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Defects. 

This brings up the Defect List data table.

Figure 4-21 Defect List data table

4 Click the Remove button next to the defect you want 
to remove. 

This opens a dialog box, asking you to confirm the 
deletion of the defect.

5 Click OK to remove the defect from the table.

Figure 4-22 Confirm the removal of the defect

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

NOTE
You can hide the removed repair action from view 
by clicking Hide Removed Items at the top of the 
table. The removed item remains in the list, but it 
is hidden from view.

To restore a defect to the Defects data table, see 
Restore a Defect.
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Restore a Defect
To restore a defect type to the defect list:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Defects. 

This brings up the Defect List data table. If removed 
defects are not currently listed in the table, click the 
Show Removed Items button at the top of the table. 
Removed defects are displayed in grayed-out rows 
and appear at the top of the table.

4 Click the Restore button for any items you want to 
restore to the Defect List data table. 

Changes are applied immediately.

5 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Figure 4-23 Defect List data table
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Reorder the Defect List
To edit the order of defects listed in the Agilent Repair 
Tool�s Defect Details dialog box:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Defects. 

This opens the Defect List data table.

4 Click the Edit Order button located above the table.

This displays the Edit Display Order sort box.

Figure 4-24 Defect List data table

5 Select the defect that you wish to move by clicking it 
with your cursor.

6 Click the arrow next to the table to move the 
highlighted selection to a different location.

To move the selection up, click the  arrow. 

To move the selection down, click the  arrow.

7 Continue clicking the arrows until the defect is in the 
desired location.

8 Repeat the above steps for any other defects you wish 
to reorder.

9 Click Apply. 

Changes are applied immediately.

10 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).
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Assign Specific Repair Actions to a Defect
To assign specific repair actions to defects in the Agilent 
Repair Tool�s Defect Details dialog box:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Defects. 

This opens the Defect List data table.

4 Locate the defect in the table.

5 Click the Repair Actions button located on the same 
row as the defect. 

This opens the Edit Repair Actions table.

Figure 4-25 Assign Specify Repair Actions to a Defect

Figure 4-26 Assigned Repair Actions table
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6 To assign a repair action, select it from the Repair 
Actions Available column, then click Add >. To 
unassign a repair action, select it from the Assigned 
Repair Actions column, then click < Remove.

7 Click Apply. 

Edits will be applied immediately.

Test Stations Display List
The Test Station Display List allows the Administrator 
to specify mappings between internally generated tester 
names and user-readable names. For instance, the 
Agilent SJ Series typically identifies itself by a serial 
number. This feature allows you to assign it a more 
meaningful name, such as �Line 6 SJ,� that will be 
displayed within ITF applications.

In ITF 3.1, it is now possible to add, edit and remove 
test stations. The following sections provide detailed 
instructions for doing so.

■ Add a Test Station

■ Edit a Test Station

■ Remove a Test Station
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Add a Test Station
To add a test station to the Display List:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Test Stations. 

This displays the Test Station Display List. Each tester 
currently connected to the Agilent Intelligent Test 
Framework is included in the list.

4 Click Add Test Station button on top of the data table.

This opens an editable dialog box at the top of the 
data table. See Figure 4-27.

5 Enter the new hostname in the Station�s Host Name 
comment box, and enter a descriptive name in the 
Station�s Display Name comment box, and then click 
Apply. 

Changes are applied immediately.

NOTE
The Station�s Host Name must be unique across 
all the test stages where as the Station�s Display 
Name must be unique for the current test stage

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Figure 4-27 Add a Test Station
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Edit a Test Station
To edit a test station to the Display List:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Test Stations. 

This displays the Test Station Display List. Each tester 
currently connected to the Agilent Intelligent Test 
Framework is included in the list.

4 Click Edit for the selected test station. 

This opens an editable dialog box on the data table.

5 Edit the new name in the Station�s Display Name 
comment box, and edit the descriptive name in the 
Station�s Display Name comment box. Click Apply. 

Changes are applied immediately.

6 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Figure 4-28 Edit a Test Station
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Remove a Test Station
To remove a test station from the Display List:

1 Click Applications > General on the main menu.

2 Click the appropriate test system mode: AOI_SJ, 
AOI_SP, AXI or ICT.

3 Click Test Stations. 

This displays the Test Station Display List. Each tester 
currently connected to the Agilent Intelligent Test 
Framework is included in the list.

4 Click Remove for the selected test station. 

This removes the selected test station from the data 
table. 

Only test stations without test results can be removed 
from the Display List. If there is data results 
associated with the test station, the Remove button 
would be disabled.

5 Repeat the above steps for each test system mode 
(AOI_SJ, AOI_SP, AXI and ICT).

Figure 4-29 Remove a Test Station
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In this chapter... ■ Overview, 5-2

■ Data Management, 5-3

■ Licenses, 5-19

■ Log Files, 5-27

■ Agent Controller, 5-28

■ Scheduled Jobs, 5-29
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Overview The Framework menu option in the ITF Administration 
System allows users to configure basic services for the 
Agilent Intelligent Test Framework.

Click Framework from the main menu. Select one of the 
following choices:

■ Data Management

■ Licenses

■ Log Files

■ Agent Controller

■ Scheduled Jobs
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Data Management System Administrators can configure the Data 
Management utility to ensure there is adequate space on 
the disk drive to perform Agilent Repair Tool and 
Agilent Quality Tool functions. The Data Viewer and 
XML Export allow you to view test and repair data.

To access the Data Management utility:

1 Click Framework > Data Management.
2 Select one of the following choices:

■ Lifetime Rules - Defines when data can be 
deleted from the data store.

■ Data Viewer - Displays test and repair data for 
selected boards. Allows you to delete data for 
individual board tests.

■ Delete Data - Specifies a specific date for 
deleting data from the data store.

■ XML Export - Saves data configuration files in 
XML format.

Lifetime Rules
Lifetime Rules define when and what type of data are 
deleted on the ITF Server.

The following rules apply:

1 All images that are older than the specified number 
of days will be deleted. (.jpg only)

2 All board test results and associated images that are 
older than the specified number of days will be 
deleted. (.jpg and test data)

To run Lifetime Rules:

1 Click Framework > Data Management on the main 
menu.

2 Click Lifetime Rules. You can modify the following 
rules and settings:

■ Minimum time to retain images.

■ Minimum time to retain board test results.

■ Frequency to run Lifetime Rules.

3 Enter values for each rule in the Value column. The 
default settings are:

■ Minimum time to retain images = 30 days

■ Minimum time to retain board test results = 30 
days
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Figure 5-1 Lifetime Rules data table

4 Select when you would like to run the Lifetime 
Rules. For each day of the week, click the drop-down 
arrow for time options. The default setting is for 
midnight (00:00) each night. If you do not want to 
run Lifetime Rules on a particular day, select Never.
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Figure 5-2 Frequency to run Lifetime Rules dialog box

NOTE
Be sure to set the Lifetime Rules to run at least 
one time during the week. You may want to set the 
Lifetime Rules to run at off-peak hours. This will 
limit its impact on the ITF Server's performance.

5 Click Apply and Run to save the changes and run the 
Lifetime Rules.

The Lifetime Rules are queued as jobs which will run 
at a preset time.  See Scheduled Jobs for more 
information.
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Data Viewer
The Data Viewer displays test and repair information for 
selected boards or panels.

To view test and repair data for a board or panel:

1 Click Framework > Data Management on the main 
menu.

2 Click Data Viewer.
A screen similar to Figure 5-3 appears.

Figure 5-3 Data Viewer

3 Select Board or Panel.

NOTE
Select Board if you want to view only the 
individual board information.  Select Panel if you 
want to view panel with multiple information . 

4 Select AOI_SJ, AOI_SP, AXI or ICT.

5 Enter the serial number of your board or panel, and 
then click Apply. The board details appears as shown 
in Figure 5-7

If there are at least two boards with same serial 
number or the same board is tested under different 
test programs, a list would appear as shown in Figure 
5-4.  Select the desired board.
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Figure 5-4 Data Viewer Same Serial Browse dialog box

Alternatively, you can click Browse for a list of 
available board or panel types and their associated 
serial numbers. Select the board type required as 
shown in Figure 5-5.

6 The last 200 board or panel serial numbers that 
matches the selected board type will appear as shown 
in Figure 5-6.
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Figure 5-5 Selecting Board Type
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Figure 5-6 Data Viewer -Browsing with the Browse button

7 Select the desired board or panel and it would be 
displayed.

A screen similar to Figure 5-7 appears.
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Figure 5-7 Test Data for AOI_SJ



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  5-11

Chapter 5: Framework: Data Management

Figure 5-8 Individual Component Test Data for AOI_SJ

8 Click View displays the details of each individual 
defect.

To view a close-up image of the component, click the 
thumbnail image.
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Figure 5-9 Sample Data for ICT
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Figure 5-10 Sample Test Data for AXI

The Repair Status column includes information from the 
Agilent Repair Tool about the status of the board.
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Figure 5-11 Icon Reference list

9 In AXI, AOI_SJ or AOI_SP mode, you can click 
View to view images associated with the defect.

Delete Data
The Delete option allows you to delete data from the 
data store based upon a specified date. All board test 
results and associated images older than the specified 
date will be deleted.

1 Click Framework > Data Management on the main 
menu.

2 Click Delete. 

A calendar appears.

Figure 5-12 Calendar dialog box

3 Click the desired date for data deletion and click 
Apply. 

All data older than the selected date is deleted.
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NOTE
The date entered must be older than the current 
date.

The deletion would be queued as a job which 
would run at a preset time.

XML Export
The XML Export function allows you to save test and 
repair data in the form of XML files. These files are 
saved in the ITF folder on a designated network PC or 
server.

Run XML Export
Before running XML Export, verify that the following 
steps have been completed:

■ Permissions and ItfService properties on the ITF 
Server have been set for the ITFUser account.

■ A network PC or server has been designated and 
configured to receive the XML files from the ITF 
Server.

These steps are typically completed during the initial 
setup of the ITF Server and Intelligent Test Framework. 
For more information on how to complete these tasks, 
please see the ITF Software Solutions Setup Guide 
(Setup_Guide.pdf) located in the C:\Program 
Files\Agilent Technologies\Intelligent Test 

Framework\Install\Documentation directory on the 
ITF Server.

To run XML Export:

1 Click Framework > Data Management on the main 
menu.

2 Click XML Export. 
The XML Export dialog box appears.
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Figure 5-13 XML Export dialog box
.

3 Choose:

■ When you want to transfer XML files: after 
boards are tested and/or after boards are repaired

■ Whether to export AOI_SJ, AOI_SP, AXI and/or 
ICT board data

■ Whether you want to include defect information 
(optional)

NOTE
You must select at least one option from the 
Enable XML Export to transfer files section and one 
option from the Include board data for section in 
order to enable XML Export. Defect information 
is optional.



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  5-17

Chapter 5: Framework: Data Management

4 Verify that the Destination box lists the hostname and 
shared folder of the network PC or server designated 
to receive the XML files. If necessary, enter the 
hostname and shared folder of the network PC or 
server.

For example, if your network PC or server's hostname is 
SERVER_NAME and the shared folder is ITF, you would 
enter the following in the Destination box: 
\\SERVER_NAME\ITF\XMLExport.

Figure 5-14 XML Export.

5 Click Apply.

CAUTION

!Running XML Export may decrease system 
performance depending upon the amount of data 
transferred to XML files.
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XML File Names
The XML file names are based on the following 
information:
SerialNumber#boardType#stage#TestStation#imag
eId#testTime#pre/postRepair#exportTime.xml

For example:

uc6050_botDemo#UC6050_Bot_ART#AOI_SJ#SJ100#0#

1017007606000#PostRepair#1049137191866.xml

Board Serial Number = uc6050_botDemo

Board Type = UC6050_Bot_ART

Stage = AOI_SJ

Test Station = SJ100

Image ID (or Board Number on panel) = 0

Test Time = 1017007606000

Date Generation (PreRepair or PostRepair) = 

PostRepair

Time XML file was created = 1049137191866

NOTE
Times are represented as the number of 
milliseconds that have passed since January 1, 
1970 00:00:00.000 GMT.

View XML Files
You can open and view XML files in Microsoft® 
Internet Explorer.

When viewing and parsing XML files, refer to the 
BoardTestXMLExport.xsd file located on the ITF 
Server under C:\Program Files\Agilent 
Technologies\Intelligent Test 

Framework\ITFInfo. The XSD file describes the 
format and content of the XML files.

XSD stands for XML Schema Description. Since the 
XSD file describes the content of the XML files 
generated by XML Export, it is a useful reference when 
writing your XML parsers.

You can open and view the BoardTestXMLExport.xsd 
file in Microsoft Internet Explorer.
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Licenses The Licenses utility allows you to view your current 
software licenses, as well as set up new licenses. You 
can also retrieve basic information about your ITF 
Server, such as its MAC address and serial number.

To manage your software license information:

1 Click Framework > Licenses on the main menu.

2 Select one of the following choices:

■ Set up - Activate a new license.

■ List - View existing licenses and expiration dates.

Setting Up Licenses
You may need to set up the licenses for the ART and 
AQT clients.

Setting up your software licenses involves three major 
steps:

■ Getting your ITF Server MAC address and serial 
number

■ Downloading the software license file from the 
Agilent Software Licensing web site

■ Activating the license file in the ITF 
Administration System

To set up your ART/AQT Client software licenses:

1 Click Framework > Licenses on the main menu.

2 Click Set Up.

3 Click ART/AQT. 

The ITF Administration System provides you with 
the following information about your ITF Server:

■ Hostname

■ MAC Address

4 Print or write down the MAC address. You will need 
it when accessing the Agilent Software Licensing 
web site.

5 From any computer with Internet access, browse to 
the Agilent Software Licensing web site at 
http://www.agilent.com/find/softwarelicense.

NOTE
It is assumed that the ITF Server does not have 
Internet access. If it does, simply browse to the 
Agilent Software Licensing web site from the ITF 
Server and follow the instructions below.

If you do not have Internet access or cannot 
contact Agilent through this web site, contact the 
Agilent Customer Support Center at 
1-800-447-TEST (U.S. only) for assistance. If you 
are located outside the U.S., please contact your 
local Agilent representative.

http://www.agilent.com/find/softwarelicense
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Figure 5-15 Example Entitlement Certificate
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6 Once at the Agilent Software Licensing web site, 
click Click here to start software license redemption.

7 Enter the Order Number and Certificate Number from 
your Entitlement Certificate, and then click Search.

8 The next window provides you with three options. 
Click Option I: Request license(s) for one or more 
software products on one instrument or host 
computer. 

NOTE
You may redeem licenses for only one ITF Server 
at a time.

9 Select the product for which you want to redeem a 
license (i.e., Agilent Repair Tool or Agilent Quality 
Tool).

The products are listed in the drop-down menu. The 
�available� and �desired� quantities are filled in 
automatically. If necessary, change the desired 
quantity for licensing. This is the number of products 
that you wish to license at this time.

10 Click Add.

The product is listed in the Selected Product List box. 
If you have more than one product for which you 
would like to redeem a software license, repeat steps 
8 and 9.

11 At the bottom of the page, enter the MAC Address of 
the ITF Server and the Product Serial Number.

12 Review the transaction and click Next.

13 Enter an email address where you can retrieve the 
license file. Click Submit.
An email will be sent to you with your license file.

14 Review and print the confirmation page.

15 Click Close to exit the Agilent Software Licensing 
web site.

16 Open your email and look for a new message from 
license_support@agilent.com. If you have 
network access to the ITF Server, copy the attached 
license file over the network to the ITF Server. 
Otherwise, copy the file to a diskette, then go over to 
the ITF Server.

CAUTION

!Check that the license file ends with a .lic file 
name extension. If the file does not have a .lic 
extension, change the file extension to .lic 
manually.

17 Return to the ITF Administration System on the ITF 
Server.

18 Click Framework > Licenses > Set Up to continue 
with the licensing process.

19 If you have copied the license file to a diskette, insert 
the diskette into the appropriate drive on the ITF 
Server.

20 Click ART/AQT.
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21 Enter the location of the license file in the Enter the 
license file path text box. You can also browse to the 
path using the Browse button.

Figure 5-16 Set Up ART/AQT Client Licenses

22 Click Next >. 

The system activates the file and the ITF License 
Information table is automatically populated to 
reflect your new license.

23 Compare the new licenses listed in the ITF License 
Information table with those listed on your 
Entitlement Certificate. They should match. If they 
are not identical, an error may have occurred during 
the licensing process. Please contact your local 
Agilent representative or the Agilent Customer 
Support Center at 1-800-447-TEST (U.S. only).
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NOTE
In order to activate additional licenses in the 
future, you will need to download a new software 
license file. See Additional Licenses for more 
information.
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Listing Licenses
The ITF License Information table lists your current 
licenses and expiration dates.

To view your current software licenses:

1 Click Framework > Licenses on the main menu.

2 Click List. 
The ITF License Information table appears.

Figure 5-17 ITF License Information table

The ITF License Information table is updated 
automatically whenever a new software license file is 
activated. See Setting Up Licenses for more 
information.

Additional Licenses
If you have an Entry or Standard ITF Server, you can 
purchase additional software licenses for the various 
ITF software applications at any time. Single-Tester ITF 
Servers are limited to only one license per application.

If you would like to purchase additional licenses, 
contact your local Agilent field representative for 
assistance. They will process your order and issue you a 
new Entitlement Certificate.

Once you receive your Entitlement Certificate, follow 
the steps listed under Setting Up Licenses.

Troubleshooting
If for some reason, you can no longer use the software 
license file after activation, use the following recovery 
process.

The following procedure will only work for the same 
MAC address for which the original license was 
processed. If no license history is found or you cannot 
locate your Entitlement Certificate, contact your local 
Agilent representative or call the Agilent Customer 
Support Center at 1-800-447-8378 (U.S. only) for 
assistance.
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To recover your license file:

1 Locate your original Entitlement Certificate. 

NOTE
If you do not have the Entitlement Certificate, you 
will not be able to retrieve your software license 
file through the Agilent Software Licensing web 
site. You will need to contact your local Agilent 
representative or call the Agilent Customer 
Support Center at 1-800-447-8378 (U.S. only) for 
assistance.

2 From any computer with Internet access, browse to 
the Agilent Software Licensing web site at 
http://www.agilent.com/find/softwarelicense.

3 Once at the Agilent Software Licensing web site, 
click Click here to start software license redemption.

4 Enter the Order Number and Certificate Number from 
your Entitlement Certificate, and click Search.

The next window provides you with three options. 
Click Option III: Get previously issued licenses for 
this order number.

5 Right-click the file listed and choose Save Target As 
to retrieve the software license file.

6 Save the software license file to a directory from 
which you can retrieve it later.

7 If you have network access to the ITF Server, copy 
the license file over the network to the ITF Server. 
Otherwise, copy the file to a diskette, then go over to 
the ITF Server.

CAUTION

!Check that the license file ends with a .lic file 
name extension. If the file does not have a .lic 
extension, change the file extension to .lic 
manually.

8 Return to the ITF Administration System on the ITF 
Server.

9 Login to the ITF Administration System on the ITF 
Server as Administrator.

10  Click Framework > Licenses > Set Up. Skip steps 1 
and 2 in the Set Up Licenses dialog box.

11 If you have copied the file to a diskette, insert the 
diskette into the appropriate drive on the ITF Server.

12 Enter the location of the license file on the ITF 
Server in the Enter the license file path text box. You 
can also browse to the path using the Browse button.

13 Click Next >. 

The system activates the file and the ITF License 
Information table is automatically populated to 
reflect your new license.

http://www.agilent.com/find/softwarelicense
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14 Compare the licenses listed in the ITF License 
Information table with those listed on your 
Entitlement Certificate. They should match. If they 
are not the same, an error may have occurred during 
the licensing process. Please contact your local 
Agilent representative or the Agilent Customer 
Support Center at 1-800-447-8378 (U.S. only).

NOTE
This process will only work for the same MAC 
address to which the original license was 
submitted. If no license history is found or you 
cannot locate your Entitlement Certificate, contact 
your local Agilent representative or call the 
Agilent Customer Support Center at 1-800- 
447-8378 (U.S. only) for assistance.

15 Store your license file together with your Entitlement 
Certificate.

16 Remove the diskette from the ITF Server drive.
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Log Files The Log Files option displays a list of log files generated 
by the ITF Server. These files contain information about 
errors encountered during operation.

To view a log file:

1 Click Framework > Log Files on the main menu.

This opens the ITF Log Files table.

Figure 5-18 ITF Log Files table

2 Click the View button next to the file you wish to 
view. 

The data is displayed in a new dialog box.

Figure 5-19 Log Files Display -ITF.log

3 Click the Back button on the browser to return to the 
original ITF Log Files table.



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  5-28

Chapter 5: Framework: Agent Controller

Agent Controller The Agent Controller utility enables you to monitor the 
status of the individual agents within the four stages. It 
enables you to start or stop the Agent locally.

Using the Agent Controller
Using the 5DX Agent Controller as a example,

To start the agent when it is stopped:

1 Click Framework > Agent Controller > AXI on the 
main menu. 

This opens the 5DX Agent Controller utility.

Figure 5-20 Agent Controller - Stopped

2 Click the Start 5DX Agent button. 

This starts the 5DX agent.

To stop the agent when it is started:

1 Click Framework > Agent Controller > AXI on the 
main menu. 

This opens the 5DX Agent Controller utility.

Figure 5-21 Agent Controller - Stopped

2 Click the Stop 5DX Agent button. 

This stops the 5DX agent.
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Scheduled Jobs When the Data Lifetime Management Rules are set, the 
jobs would not run immediately.  Instead, they are 
placed in a queue. The ITF Server would only run these 
jobs at the appointed time. The Scheduled Jobs on the 
main menu provides a mean of managing the jobs.  The 
jobs can only be removed after it is done processing.

Viewing Scheduled Jobs
To view the scheduled jobs:

1 Click Framework > Scheduled Jobs on the main 
menu. 

This opens a Scheduled Jobs Information table 
similar to the one shown in Figure 5-22.

Figure 5-22 Scheduled Jobs Information - Data Lifetime Management Rules

2 Click Remove to clear completed jobs.

3 Repeat accordingly for each job to remove.
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NOTE
Jobs which are being processed appear in cyan 
and cannot be removed.

Queued jobs which are not currently in process 
can be removed.
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6 Help

In this chapter... ■ Working in Comfort, 6-2

■ Technical Support, 6-3

■ Phone Support, 6-4

■ Sales and Product Information, 6-5
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Working in Comfort To optimize your comfort and productivity, it is 
important that you set up your work area correctly and 
use your equipment properly. With that in mind, Agilent 
Technologies has developed some setup and use 
recommendations for your work station. Please click the 
link below to learn important information based on 
established ergonomic principles.

http://www.agilent.com/quality/Working_In_Comfort.pdf

http://www.agilent.com/quality/Working_In_Comfort.pdf
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Technical Support The Agilent Technologies Printed Circuit Board Test 
and Inspection web site is for the benefit of owners and 
users of the Agilent Quality Tool, the Agilent Repair 
Tool, and Agilent Technologies� board test and 
inspection systems. 

Visit the web site at: http://www.agilent.com/see/pcb 

NOTE
A login is required for access to service 
documentation and downloads.

Topics available from the web site include the 
following:

■ Application Notes and Technical Papers

■ Data Sheets, Brochures, Demonstrations and 
Catalogs

■ Frequently-Asked Questions (FAQs)

■ Manuals, Guides and Notifications

■ Newsletters, Presentations, and Articles

■ Software, Firmware and Drivers
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Phone Support Phone-based support is included for the first year of 
purchase and is highly recommended for subsequent 
years.

Customers can call a 24-hour toll free support phone 
number. 

■ In the United States, the phone number is 
1-800-447-8378.  

■ Customers in the rest of the world can call their 
local support.

For more information about support services, go to the 
Agilent Technologies web site at 
http://www.agilent.com/see/pcb or contact your local 
Agilent Technologies field representative.
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Sales and Product 
Information

■ For more information about Agilent Technologies 
products and services in electronics 
manufacturing, visit our web site: 
http://www.agilent.com/see/pcb

■ To learn about other Agilent Technologies test 
and measurement products, applications and 
services, or for a current sales office listing, visit 
our web site: http://www.agilent.com/find/tmdir 

http://www.agilent.com/see/pcb
http://www.agilent.com/find/tmdir
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7 Resource

In this chapter... ■ Overview, 7-2

■ Migration, 7-3
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Chapter 7: Resource: Overview

Overview The Resource section of the Administration System 
migrates the old data of the ITFSS 3.0 to ITFSS 3.1.
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Migration The following tasks can be performed in Resource for 
Migration:

■ Add A Migration Job

■ Remove A Migration Job

■ Restore A Migration Job

■ Migrate All Data

Add A Migration Job
To migrate a specific range of data:

1 Click Resource > Migration.

A calendar appears (see Figure 7-1).

2 To migrate a specific range of board test data, click 
<< or >> to select year, click < or > to select 
month,then click the date.

Figure 7-1 Migration of Data dialog box
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In this example the range of test board data available 
is from Jul 27, �04 12:07 to Aug 5, �04 10:08

a If a date earlier than Jul 27, �04 12:07 is selected, 
a message box appears (see Figure 7-2), click OK 
and re-select a later date.

Figure 7-2 Error message indicating a later date is 
required

b If a date later than Aug 5, �04 10:08 is selected, a 
message box appears (See Figure 7-3), click OK 
and re-select a earlier date.

Figure 7-3 Error message indicating a later date is 
required

3 For example, to migrate the data from Aug 1, �04 to 
Aug 5, �04, click 1 in the month August 2004 and 
click the Apply button.

A dialog box opens to confirm if the range is correct. 
Click OK to start.

Figure 7-4 Dialog box to confirm range of data



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  7-5

Chapter 7: Resource: Migration

The queued job is shown in Figure 7-5.

Figure 7-5 Data Migration Job Summary - 1 job queued

NOTE
The job changes status to �processing� as shown 
in Figure 7-6 once it starts.

Figure 7-6 Data Migration Job Summary - 1 job being processed

4 To migrate another range, for example Jul 31, �04 to 
Aug 1, �04, the same procedure as in step 3 is 
repeated. The new job is queued for processing later.
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Figure 7-7 Job summary - 1 job pending and 1 job processing

Remove A Migration Job
To remove a migration job scheduled earlier:

1 Click Resource > Migration.

The Job Summary screen similar to the one shown in 
Figure 7-7 appears.

In this example, we would like to remove the job 
numbered 2 in the Index.

2 Click the remove button. 

The Action status button changes to restore as shown 
in Figure 7-8.

NOTE
The job which has been removed can be restored.

However, when the job is restored, it would only 
start after the currently scheduled jobs have been 
completed.

Figure 7-8 Job summary - Scheduled job 2 removed
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Restore A Migration Job
To restore a migration job scheduled earlier:

1 Click Resource > Migration.

The Job Summary screen similar to the one shown in 
Figure 7-8.

In this example, we would like to restore the job 
numbered 2 in the Index.

2 Click the restore button. 

The Action status button changes to remove as shown 
in Figure 7-9.

NOTE
The jobs which has been restored would only start 
after the currently scheduled jobs have been 
completed.

Figure 7-9 Job summary - Scheduled Job restored



© Agilent Technologies 2001�2005 Agilent ITF Administration System User Guide  7-8

Chapter 7: Resource: Migration

Migrate All Data
To migrate all data:

1 Click Resource > Migration.

A calendar appears. See Figure 7-10.

2 To migrate all board test data, select the To migrate 
all board test data check box and then click Apply.

The job to migrate all data is then scheduled and it 
appears under Job Summary.

Figure 7-10 Migration of Data dialog box

NOTE
Once all the jobs have been scheduled, the 
calendar is replaced with a notice that there is �No 
more data to migrate.�
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Figure 7-11 Completion of job scheduling - �No More Data to Migrate.�

Job Summary Status
The following is a list of possible statuses for the job 
summary:

■ Completed - This means all board test data 
selected between the timeframe in the job has 
been migrated.

■ Pending - This means the job is waiting to start.

■ Processing - This indicates that the job is 
currently being processed.

■ Queuing - This means the job is still waiting to be 
started. (This only occurs when the first job is 
scheduled.)
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A XML File Definitions

Overview This appendix provides information on Pre-Repair and 
Post-Repair XML file definitions found in the 
BoardTestXMLExport.xsd file for the following 
elements.

■ Pre-Repair XML File Definitions, A-2

■ Post-Repair XML File Definitions, A-9
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Pre-Repair XML File 
Definitions

This provides information on Pre-Repair XML file 
definitions for the following elements.

■ BoardTestXMLExport, A-3

■ BoardXML, A-4

■ StationXML, A-6

■ TestXML, A-6

■ IndictmentXML, A-7

■ ComponentXML, A-7
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BoardTestXMLExport
The following tables list the attributes and elements in 
BoardTestXMLExport and their definitions.
 

Table A-1 BoardTestXMLExport attributes

Attribute Definition

testTime Time recorded when Agilent tester starts to inspect this board

testerTestStartTime Time recorded when Agilent tester starts to inspect this board

testerTestEndTime Time recorded when Agilent tester finishes the inspection of this board

numberOfComponentsTested Number of components tested by Agilent tester for this board

numberOfJointsTested Number of pins tested by Agilent tester for this board

numberOfIndicatedComponents Number of failed components called by Agilent tester for this board

numberOfIndicatedPins Number of failed pins called by Agilent tester for this board

numberOfDefects Total number of defects found for this board

testStatus Test status of this board after the inspection by Agilent tester

repairStatus Repair status of this board after inspection at Agilent 
Rule:
if testStatus equals to "Failed"

repairStatus set to "Active"

if testStatus equals to "Passed"
repairStatus set to "Repair None"
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BoardXML
The following tables list the attributes in BoardXML 
and their definitions.
 

Table A-2 BoardTestXMLExport elements

Element Name Definition

BoardXML refer to definition for BoardXML

StationXML refer to definition for StationXML

TestXML refer to definition for TestXML

Table A-3 BoardXML attributes

Attribute Definition

serialNumber Serial number (Bar-code) on this board

imageId Board number defined for this board

boardType Board Type

boardRevision Board Revision
Rule:

a AOI_SP / AOI_SJ: The last modified date of the .pls file which is associated with 
the .rep file

b AXI: The concatenation of board numbers in the panel plus checksum of 
.cx file

c ICT: The last modified date of the GenCAM file which has the same 
name as the Board Type
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assemblyRevision Assembly Revision
Rule:

a AOI_SP / AOI_SJ: Board Name obtains from the first line of the .rep file

b AXI: Panel Name obtains from .res file

c ICT: Board Type obtains from the BATCH record of the log file

Table A-3 BoardXML attributes (continued)

Attribute Definition
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StationXML
The following tables list the attributes in StationXML 
and their definitions.
 

TestXML
The following tables list the attribute and element in 
TestXML and their definitions.

Table A-4 StationXML attributes

Attribute Definition

testerName Name of Agilent Tester machine where this board is tested

stage Type of Agilent Tester (AOI_SJ, AOI_SP, AXI or ICT)

Table A-5 TestXML attribute

Attribute Definition

name Name of the test step
     
Rule:

a AOI_SP / AOI_SJ: Reference designator 

b AXI: The sorted joint number

c ICT: Test designator obtains from test records found in log file
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IndictmentXML
The following tables list the attributes and elements in 
IndictmentXML and their definitions.

ComponentXML
The following tables list the attributes ComponentXML 
and their definitions.

Table A-6 TestXML element

Element Name Definition

IndictmentXML refer to definition for IndictmentXML

Table A-7 IndictmentXML attributes

Attribute Definition

indictmentType Type of defect found on this component in this board

algorithm Algorithm used to test this component in this board

algorithmSubType Sub-algorithm used to test this component in this board (AXI only)

Table A-8 IndictmentXML elements

Element Name Definition

ComponentXML refer to definition for ComponentXML
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Table A-9 ComponentXML attributes

Attribute Definition

designator Reference Designator of this component in this board

pin Pin Number of this component in this board (AXI only)

partId Part Number of this component in this board (AOI_SJ only)

packageId Package type of this component in this board



© Agilent Technologies 2001�2005 Agilent ITF Software Solutions Setup Guide  A-9

Appendix A: XML File Definitions: Post-Repair XML File Definitions

Post-Repair XML File 
Definitions

This appendix provides information on Post-Repair 
XML file definitions for the following elements.

■ BoardTestXMLExport, A-10

■ BoardXML, A-12

■ StationXML, A-13

■ RepairEventXML, A-13

■ TestXML, A-15

■ IndictmentXML, A-15

■ RepairActionXML, A-16

■ ComponentXML, A-17
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BoardTestXMLExport
The following tables list the attributes and elements in 
BoardTestXMLExport and their definitions.
 

Table A-10 BoardTestXMLExport attributes

Attribute Definition

testTime similar to Pre-Repair case

testerTestStartTime similar to Pre-Repair case

testerTestEndTime similar to Pre-Repair case

numberOfComponentsTested similar to Pre-Repair case

numberOfJointsTested similar to Pre-Repair case

numberOfIndicatedComponents similar to Pre-Repair case

numberOfIndicatedPins similar to Pre-Repair case

numberOfDefects similar to Pre-Repair case

testStatus similar to Pre-Repair case
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repairStatus Repair status of this board after board opened at ART client
Rule:
if testStatus equals to "Failed"

repairStatus set to "Active"

if testStatus equals to "Passed"
repairStatus set to "Repair None"

if testStatus equals to "Reviewed Passed"
repairStatus set to "Reviewed Passed"

if testStatus equals to "Reviewed Failed"
repairStatus set to "Reviewed Failed"

if testStatus equals to "Repaired"
repairStatus set to "Repaired"

if testStatus equals to "Scrapped"
repairStatus set to "Repair None"

Table A-10 BoardTestXMLExport attributes (continued)

Attribute Definition



© Agilent Technologies 2001�2005 Agilent ITF Software Solutions Setup Guide  A-12

Appendix A: XML File Definitions: Post-Repair XML File Definitions

BoardXML
The following tables list the attributes in BoardXML 
and their definitions.
 

Table A-11 BoardTestXMLExport elements

Element Name Definition

BoardXML refer to definition for BoardXML

StationXML refer to definition for StationXML

RepairEventXML refer to definition for RepairEventXML

TestXML refer to definition for TestXML

Table A-12 BoardXML attributes

Attribute Definition

serialNumber similar to Pre-Repair case

imageId similar to Pre-Repair case

boardType similar to Pre-Repair case

boardRevision similar to Pre-Repair case

assemblyRevision similar to Pre-Repair case
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StationXML
The following tables list the attributes in StationXML 
and their definitions.
 

RepairEventXML
The following tables list the attributes in 
RepairEventXML and their definitions.
  

Table A-13 StationXML attributes

Attribute Definition

testerName similar to Pre-Repair case

stage similar to Pre-Repair case

Table A-14 RepairEventXML attributes

Attribute Definition

repairStartTime Time recorded when the ART client start the repair on the board

repairEndTime Time recorded when the ART client ends the repair on the board

repairOperator Name of the ART client repair operator

numberOfActiveDefects Number of active defects remaining on the board after the board has been repaired 
by the ART client

numberOfActiveComponents Number of active components remaining on the board after the board has been 
repaired using the ART client

numberOfActivePins Number of active pins remaining on the board after the board has been repaired 
using the ART client
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numberOfFalseCalledDefects Number of false called defects remaining on the board after the board has been 
repaired using the ART client

numberOfFalseCalledComponents Number of false called components remaining on the board after the board has 
been repaired using the ART client

numberOfFalseCalledPins Number of false called pins remaining on the board after the board has been 
repaired using the ART client

numberOfRepairedDefects Number of repaired defects remaining on the board after the board has been 
repaired using the ART client

numberOfRepairedComponents Number of repaired components remaining on the board after the board has been 
repaired using the ART client

numberOfRepairedPins Number of repaired pins remaining on the board after the board has been repaired 
using the ART client

numberOfRepairLaterDefects Number of repair later defects remaining on the board after the board has been 
repaired using the ART client

numberOfRepairLaterComponents Number of repair later components remaining on the board after the board has been 
repaired using the ART client

numberOfRepairLaterPins Number of repair later pins remaining on the board after the board has been 
repaired using the ART client

numberOfVariationOkDefects Number of variation ok defects remaining on the board after the board has been 
repaired using the ART client

numberOfVariationOkComponents Number of variation ok components remaining on the board after the board has 
been repaired using the ART client

numberOfVariationOkPins Number of variation ok pins remaining on the board after the board has been 
repaired using the ART client

Table A-14 RepairEventXML attributes (continued)

Attribute Definition
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TestXML
The following tables list the attribute and element in 
TestXML and their definitions.

  

IndictmentXML
The following tables list the attributes and elements in 
IndictmentXML and their definitions.

Table A-15 TestXML attribute

Attribute Definition

name similar to Pre-Repair case

Table A-16 TestXML element

Element Name Definition

IndictmentXML refer to definition for IndictmentXML

Table A-17 IndictmentXML attributes

Attribute Definition

indictmentType similar to Pre-Repair case

algorithm similar to Pre-Repair case

algorithmSubType similar to Pre-Repair case
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RepairActionXML
The following tables list the attributes 
RepairActionXML and their definitions.
   

Table A-18 IndictmentXML elements

Element Name Definition

RepairActionXML refer to definition for RepairActionXML

ComponentXML refer to definition for ComponentXML

Table A-19 RepairActionXML attributes

Attribute Definition

repairTime Time recorded when ART client starts to repair this board

repairOperator Name of the ART client repair operator

repairStatus Repair status of this component

indictmentType Type of defect found on this component in this board

repairActionType Type of repair action carried out for this component in this board

comment Additional comments defined for this repair action
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ComponentXML
The following tables list the attributes ComponentXML 
and their definitions.

Table A-20 ComponentXML attributes

Attribute Definition

designator similar to Pre-Repair case

pin similar to Pre-Repair case

partId similar to Pre-Repair case

packageId similar to Pre-Repair case
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A
Administration System: see ITF Administration System.
Administrator role: The Administrator role has the 
second-highest level of permission in the ITF Administration 
System. Permissions for this role are set by the System 
Administrator role. There are no restrictions on the number of 
users with Administrator permissions. A System Administrator 
can assign an unlimited number of users or none to this role. 
There is no limit on the amount of concurrent users logged in 
as Administrators.
Agilent 3070: Agilent Technologies' in-circuit board test 
system family.
Agilent 5DX: Agilent Technologies' x-ray inspection system. 
Automated X-ray Inspection (AXI) uses 3-D x-ray testing to 
locate manufacturing defects. In addition, it does not require 
in-circuit test probing or visual access and does not require a 
fixture. AXI pinpoints the exact location of the defects; thus, 
repairs are both fast and inexpensive.
Agilent Intelligent Test Framework: A collective term that 
refers to the Agilent Intelligent Test Framework software and 
server.
Agilent Intelligent Test Framework software: The software 
that allows for data sharing and communication among test 
systems and applications, such as the Agilent Repair Tool and 
Agilent Quality Tool.
Agilent Quality Tool: An SPC/SQC tool for the Agilent 5DX 
and Agilent AOI inspection systems. The Agilent Quality Tool 

allows users to apply SPC and SQC methods to improve 
assembly and test process efficiencies while helping them 
meet targeted quality levels. The Agilent Quality Tool is a 
software application that runs on Client PCs.
Agilent Repair Tool: The common repair tool for the Agilent 
3070, Agilent 5DX, and Agilent SJ Series test systems. The 
Agilent Repair Tool is a software application that runs on 
Client PCs. Common abbreviation is ART.
Agilent SJ Series: Agilent Technologies' optical inspection 
system. Automated Optical Inspection, Solder Joint (AOI_SJ) 
uses cameras to inspect components on printed circuit 
boards. AOI_SJ can be used to check for presence-absence, 
skew, character markings, and polarity.
AOI_SJ: Automated Optical Inspection, Solder Joint. The 
Agilent SJ10 and SJ50 are automated optical inspection 
solder joint (AOI_SJ) systems.
AOI_SP: Automated Optical Inspection,Solder Paste. The 
Agilent SP50 is an automated optical inspection, solder paste 
(AOI_SP) system.
ART: Abbreviation for Agilent Repair Tool.
AXI: Automated X-ray inspection. The Agilent 5DX X-ray 
inspection system is an AXI system.

B
board: (1) The physical object containing the devices 
intended for test. (2) A term used by 3070 users to refer to a 
printed circuit board assembly (called a panel by Agilent 5DX 
users).
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broken files: Files that were not parsed by the ITF Server. 
The Broken Files option in the ITF Administration System 
allows you to view and reparse broken files.

C
CAD: Abbreviation for Computer Aided Design. For the 
Agilent 5DX or Agilent SJ Series inspection systems, CAD 
data is the source data used to design or describe an 
unpopulated circuit board. For Agilent in-circuit test machines, 
CAD data is used to describe the layout of a printed circuit 
board to the test machine.
CAD Manager: A utility in the ITF Administration System that 
allows the user to manage the CAD data files.
Client PC: The computer on which the Agilent Repair Tool or 
Agilent Quality Tool software runs.
close board: An action taken in the Agilent Repair Tool to 
close an active board.
component: An individual part with contacts (pins) that are 
connected with solder joints to a corresponding set of pads 
(land pattern) on a board. Also called a Device.
Computer-aided design: See CAD.

D
dashboard: The group of live charts on a tab in the Agilent 
Quality Tool, used to monitor quality, throughput, or false call 
levels.
Data Store: The subsystem within the Intelligent Test 
Framework where the test and repair information is stored.
Data Viewer: A utility in the ITF Administration System that 
displays a list of files associated with a board. These files 

contain a record of the errors and information that the Agilent 
ITF has encountered while processing the data for the board.
defect: An unacceptable deviation from a norm.
defect call: An item in the Defect Table or defect list. A 
possible defect.
Defect Details: A dialog box in the Agilent Repair Tool. Allows 
the user to enter more specific details about repair actions and 
defects.
Defect List: A user-defined list of defect types, such as OPEN 
or SHORT. The list is configured in the ITF Administration 
System and used in Agilent ITF applications. The defects 
listed in the Agilent Repair Tool are based upon the Defect 
List.
device: A component.

F
Framework: See Agilent Intelligent Test Framework.
function key: A programmable key on a computer keyboard 
(conventionally numbered F1, F2, etc.). Function keys often 
provide special functions, depending on the application 
currently running on that PC.

I
ICT: An acronym for in-circuit test. The Agilent 3070 is an 
in-circuit test system.
image: An X-ray or optical image of a possible defect. X-ray 
laminography allows for X-ray images from X-ray inspection 
(AXI) systems, such as the Agilent 5DX. Automated optical 
inspection allows for optical images from AOI_SJ test 
systems, such as the Agilent SJ10 or SJ50.
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in-circuit test: An analog or digital test technique that 
measures the value or performance of a component on the 
board under test. Abbreviated as ICT.
indictment: A possible defect. A defect call.
input device: A device used to enter information into a 
computer. Examples include a keyboard, mouse, barcode 
reader, or a keypad.
Intelligent Test Framework: See Agilent Intelligent Test 
Framework
Intelligent Test Framework Server: The server hardware on 
which the Agilent Intelligent Test Framework software runs.
Intelligent Test Framework Software Solutions: A suite of 
software applications that run on the Agilent Intelligent Test 
Framework.
interface: Interaction or communication is achieved at an 
interface. A user interface is a computer screen where you 
receive and/or enter information.
ITF Administration System: A browser-based application 
used to configure system properties, such as user access, 
repair configurations and framework services for Agilent ITF 
applications. It is a software program located on the Agilent 
Intelligent Test Framework Server.
ITF Applications: A term used to describe Agilent 
Technologies, Inc. software applications developed 
specifically for use with the Agilent Intelligent Test Framework.
ITF Server: See Intelligent Test Framework Server.
ITF Software Solutions: See Intelligent Test Framework 
Software Solutions.

K
keypad: A keypad is an optional input device comprised of 
buttons for the most commonly used functions in the Agilent 
Repair Tool.

L
LAN: See Local Area Network.
Lifetime Rules: A set of rules defining when test, inspection, 
and repair data is deleted by the ITF Server. The rules are 
defined in the ITF Administration System.
local area network: A group of computers at a single location 
(usually an office or home) that are connected by phone lines 
or coaxial cable.
log in: The method to establish communication with a 
computer program. When an Agilent ITF application starts up, 
the user must first log in to the program. Login requires a valid 
user name and password. Your System Administrator sets up 
the list of valid user names and passwords.
log out: The method to end communication with a computer 
program. A user will log out when he/she wants to end 
communication with the program. Another user may then log 
in to the application.

P
panel: A printed circuit board assembly which can contain one 
or more boards. Note: For the Agilent 5DX, any single board 
loaded directly into the tester is considered a panel for the 
purpose of panel programming.
password: An individual identification code required to 
access a board, file, computer or program. The password 
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helps ensure that unauthorized users do not access the 
computer.
PIN: Personal Identification Number (a numeric password)

Q
Quality Administrator role: Users assigned to the Quality 
Administrator role can access the quality configuration or the 
quality administration tool. Permissions for this role are set by 
the System Administrator or Administrator role.
Quality Tool: See Agilent Quality Tool.
Quality User role: Users assigned to this role can only 
access the Agilent Quality Tool. Permissions for this role are 
set by the Administrator or Quality Administrator . The 
maximum number of concurrent users is limited by the 
software license. Users can change their passwords through 
the Agilent Quality Tool.

R
repair action: An action taken by the Repair Operator to 
repair or disposition a specific defect. A list of common repair 
actions, such as SOLDER RETOUCHED or COMPONENT 
REPLACED, can be defined in the ITF Administration System. 
This list is included in the Agilent Repair Tool user interface.
Repair Administrator role: Users assigned to the Repair 
Administrator role can access the repair configuration or the 
repair administration tool. Permissions for this role are set by 
the System Administrator or Administrator role.
Repair client: The Client PC on which the Agilent Repair Tool 
software runs.
Repair User role: Users assigned to this role can only access 
the Agilent Repair Tool. Permissions for this role are set by the 

Administrator or Repair Administrator. The maximum number 
of concurrent users is limited by the software license. Repair 
users can change their passwords through the Agilent Repair 
Tool.
repaired: An action taken to confirm or change the specific 
defect for this pin or component. This defect has been 
addressed.

S
serial number: A unique series of numbers and/or letters 
used to identify an individual board or panel. Usually encoded 
on a barcode label. A multi-board panel may have multiple 
board serial numbers associated with a single panel serial 
number.
software license file: A file containing Agilent Technologies 
licensing permissions. It is downloaded from the Agilent 
Technologies web site. The file must be obtained in order to 
activate software licenses.
SPC: Acronym for Statistical Process Control.
SQC: Acronym for Statistical Quality Control.
status: The status of a component or pin in the Agilent Repair 
Tool. Status is Active, Repaired, Repair Later, False Call or 
Variation OK.
status buttons: Two to four buttons located in the Agilent 
Repair Tool user interface that are used when dispositioning 
defects. They are named Repaired, Repair Later, False Call, 
and Variation OK. Repaired and False Call are required in the 
interface, but Repair Later and Variation OK are optional and 
can be set using the ITF Administration System.
System Administrator role: The System Administrator role 
has the highest-level permissions of any account and is the 
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only role that can assign or remove Administrator privileges. 
This role is automatically set up during installation with 
administrator privileges. This is a single, permanent account 
with login name Administrator.

T
test station: A specific test or inspection system, identified by 
a name or identification number.
test system: A generic term used to describe a test or 
inspection machine, such as the Agilent 3070, Agilent 5DX, or 
Agilent SJ Series.
three-tier architecture: A software architecture generally 
comprised of three layers: data store, business logic, and 
applications.

U
user name: Name used to log in to an Agilent ITF application 
from the Login dialog box. The System Administrator sets up 
all user names.
user role: Allows access to a particular software application. 
Users of Agilent ITF applications must be assigned at least 
one user role. Different roles allows for different levels of 
access to the software features.

V
View: A group of selected test stations and board types. A 
view defines a subset of test, inspection, and repair data that 
resides on the ITF Server, forming the basis for charts in the 
Agilent Quality Tool. Views are created and named in the 
Agilent Quality Tool.

X
x-ray: A dialog box of electromagnetic radiation, similar to 
light, but of shorter wavelength and capable of penetrating 
solid materials. Used by X-ray inspection machines to 
examine printed circuit board joints.
XML: Abbreviation for Extensible Markup Language. XML is a 
specification developed by the World Wide Web Consortium. It 
allows designers to create their own customized tags, 
enabling the definition, transmission, validation, and 
interpretation of data between applications and between 
organizations.
XML Export: A utility in the ITF Administration System that 
exports XML files. The XML files include test and repair data.
XSD: Acronymn for XML Schema Description. The 
BoardTestXMLExport.xsd file describes the format and 
content of XML files generated by the ITF Administration 
System's XML Export tool.
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